WordPress后台提示正在运行不安全的PHP版本是怎么回事?

2020年6月23日16:24:33 发表评论 293 次浏览

WordPress后台提示正在运行不安全的PHP版本是怎么回事?

今日,WordPress网站后台突然提示正在运行不安全的PHP版本,需要升级php怎么回事?

WordPress检测到您正在运行不安全的PHP版本。什么是PHP?为什么它影响我的站点?PHP是我们用以构建及维护WordPress的程序语言。新版本的PHP既快又安全,所以更新PHP会为您的站点带来更快的性能。
WordPress后台提示正在运行不安全的PHP版本是怎么回事?

官方解释如下:

PHP是WordPress建立在其上的编码语言,其版本由托管公司在服务器级别设置。尽管您可能熟悉保持WordPress及其主题和插件为最新的重要性,但保持PHP为最新也同样重要。

使PHP保持最新状态有两个主要好处:

  • 最新版本的PHP更有效,您的网站将更快。更新到最新的受支持版本(当前为7.4)可以极大地提高性能。对于较旧的版本,速度提高了3到4倍。
  • 您的网站将更加安全。与WordPress一样,PHP由其社区维护。由于PHP非常流行,因此它是黑客的目标-但最新版本将具有最新的安全功能。较旧的PHP版本没有此功能,因此更新对于确保WordPress网站的安全至关重要。

然后有许多次要好处:

  • 更快的WordPress网站将受到搜索引擎的奖励,因此您在搜索中的排名会更高!
  • 速度更快的网站可以更好地吸引访问者(如果加载时间太长,他们会离开),从而使您的网站更有效。
  • 一个更安全的网站可以更好地保护免受黑客攻击,以及与被黑客入侵的网站相关的成本和声誉损失。

这些好处对您有利,对您网站的访问者也有利。这些就是您今天应该更新PHP的原因。下一节将向您展示如何执行此操作。

也就是说,要将php更新到最新版本,目前的建议是7.4版本更合适,也更安全。

Austin

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: